Install OpenTTD (Transport Tycoon Deluxe) under Ubuntu

  • warning: Illegal string offset 'files' in /data/web/1/000/027/003/273448/htdocs/panticz.de/modules/upload/upload.module on line 281.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.

wget -O - | bash -s

#!/bin/bash

if [ "$1" == "-n" ]; then
# install latest version from homepage
if [ "$(uname -m)" == "x86_64" ]; then
# 64 bit
URL=http://binaries.openttd.org/releases/1.5.0/openttd-1.5.0-linux-ubuntu-trusty-amd64.deb
else
# 32 bit
URL=http://binaries.openttd.org/releases/1.5.0/openttd-1.5.0-linux-ubuntu-trusty-i386.deb
fi

# download
wget ${URL} -P /tmp

# install
sudo dpkg -i /tmp/openttd-*-linux-ubuntu-*.deb
else
# installed version provided by the distribution
sudo apt-get install -y openttd
fi

# install music
sudo apt-get install -y openttd-opensfx openttd-openmsx timidity

Install newest Version
wget -O - | bash -s -- -n

#
# OLD?
#
# sudo apt-get install -y libsdl1.2debian

# pre configure
debconf-set-selections <<\EOF
openttd openttd/datafiles select
EOF

# install openttd
sudo apt-get install -y openttd timidity
wget -P /tmp
mkdir /tmp/ttd
unrar x /tmp/ttdwin302011.rar /tmp/ttd

# copy data
sudo cp /tmp/ttd/*.grf /tmp/ttd/*.cat /usr/share/games/openttd/data
sudo cp /tmp/ttd/gm/* /usr/share/games/openttd/gm

# clean up
rm /tmp/ttdwin302011.rar
rm -r /tmp/ttd

# Links