Install Kodi

  • warning: Illegal string offset 'files' in /data/web/1/000/027/003/273448/htdocs/panticz.de/modules/upload/upload.module on line 281.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.

Install stable version
wget -O - | bash -

#!/bin/bash

sudo apt-get install -qq -y python-software-properties pkg-config

if [ "$1" == "-u" ]; then
# add unstable repository
sudo add-apt-repository -y ppa:team-xbmc/unstable

RELEASE=$(lsb_release -rs | tr -d ".")
if [ ${RELEASE} -gt 1110 ]; then
# downgrade to oneiric (lastest available release)
sudo sed -i "s|$(lsb_release -cs)|oneiric|g" /etc/apt/sources.list.d/team-xbmc-unstable-*.list
fi
else
# add stable repository
sudo add-apt-repository -y ppa:team-xbmc/ppa

RELEASE=$(lsb_release -rs | cut -d"." -f1)
if [ ${RELEASE} -gt 10 ]; then
# downgrade to maverick (lastest available release)
sudo sed -i "s|$(lsb_release -cs)|maverick|g" /etc/apt/sources.list.d/team-xbmc-ppa-*.list
fi
fi

# update
sudo apt-get update -qq

# install xbmc
sudo apt-get install -qq -y xbmc

# install required libraries
sudo apt-get install -qq -y libmad0 libmpeg2-4

install unstable version
wget -O /tmp/install.xbmc.sh
bash /tmp/install.xbmc.sh -u

Unofficial PVR repository
sudo add-apt-repository ppa:lars-opdenkamp/xbmc-pvr

XBMC standalone
sudo apt-get install -y xbmc xbmc-standalone

Configuring a Wii Remote