Install fcpci (AVM Fritz Card PCI kernel module)

  • warning: Illegal string offset 'files' in /data/web/1/000/027/003/273448/htdocs/panticz.de/modules/upload/upload.module on line 281.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
#!/bin/bash
 
# install capiutils
apt-get install -y capiutils
sed -i 's|#fcpci|fcpci|g' /etc/isdn/capi.conf
 
# install kernel module for AVM Fritz card PCI or compile: http://www.panticz.de/ubuntu_compile_fcpci
apt-get install wget
wget http://dl.dropbox.com/u/4170695/www/fcpci.tar.bz2 -P /tmp
tar xjf /tmp/fcpci.tar.bz2 -C /tmp/
/tmp/fcpci/install.sh
reboot
 
apt-get install -y asterisk asterisk-chan-capi
# do we need this? # apt-get install logrotate
 
# apt-get install asterisk-app-fax
# apt-get install asterisk-mp3 - mp3 support
#  apt-get install asterisk-prompt-de - german voice suport
 
# configure for Diva Server 4BRI-8M 2.0 PCI
cp /etc/asterisk/modules.conf /etc/asterisk/modules.conf.org
sed -i 's|noload => chan_capi.so|load => chan_capi.so|g' /etc/asterisk/modules.conf
cp /etc/asterisk/capi.conf /etc/asterisk/capi.conf.org
wget http://www.panticz.de/sites/default/files/capi.conf -O /etc/asterisk/capi.conf
 
 
# test
capiinfo
capifax -v YOUR_FAX_NO /etc/hosts