LibreOffice / OpenOffice

  • warning: Illegal string offset 'files' in /data/web/1/000/027/003/273448/htdocs/panticz.de/modules/upload/upload.module on line 281.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.
  • warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /data/web/1/000/027/003/273448/htdocs/panticz.de/includes/unicode.inc on line 349.

wget -O - | bash -

#!/bin/bash

# add ppa repository
sudo add-apt-repository -y ppa:libreoffice/ppa
sudo apt-get update -qq

# install
sudo apt-get install -y libreoffice
sudo apt-get install -y libreoffice-gnome libreoffice-help-de libreoffice-l10n-de libreoffice-officebean libreoffice-java-common libreoffice-base
sudo apt-get install -y hunspell-de-de hunspell-en-us hyphen-de mythes-de

# remove unnecessary gnome menu entries
sed -i 's|Education;Science;||' /usr/share/applications/libreoffice-math.desktop

# fix libjpipe
[ -f /usr/lib/libjpipe.so ] || sudo ln -s /usr/lib/libreoffice/program/libjpipe.so /usr/lib/libjpipe.so

# do we need this?
#sudo apt-get install -y openoffice.org openoffice.org-style-human openoffice.org-java-common

Configure default paper size
echo "a4" > /etc/papersize

# fix broken libjpipe.so /
ln -s /usr/lib/libreoffice/program/libjpipe.so /usr/lib/libjpipe.so

#http://artfiles.org/documentfoundation.org/libreoffice/stable/5.0.1/deb/x86_64/LibreOffice_5.0.1_Linux_x86-64_deb.tar.gz
#dpkg -x libreoffice5.0-ure_5.0.1.2-2_amd64.deb /tmp/
#dpkg -i libreoffice5.0-ure_5.0.1.2-2_amd64.deb
#ln -sf /opt/libreoffice5.0/program/libjpipe.so /usr/lib/libjpipe.so

# optional, start LibreOffice quicksart to speedup
ln -s /usr/lib/libreoffice/share/xdg/qstart.desktop /etc/xdg/autostart/

Links




- Release Plan
- Official downloads (deb)